Monday, 4 August 2014

Linux Kernel 3.16 Stable is Now Available! Install Linux Kernel 3.16 in Ubuntu/Linux Mint Systems

    The Linux Kernel 3.16-Stable is now available for the users, announced Linus Torvalds. This Linux Kernel version comes with plenty of fixes and improvements. This article will guide you to install or upgrade to Linux Kernel 3.16 in your Ubuntu or Linux Mint system.



Installation

For 32-Bit Systems

Download the .deb packages.

$ wget kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-headers-3.16.0-031600_3.16.0-031600.201408031935_all.deb

$ wget kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-headers-3.16.0-031600-generic_3.16.0-031600.201408031935_i386.deb

$ wget kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-image-3.16.0-031600-generic_3.16.0-031600.201408031935_i386.deb
Install them.

$ sudo dpkg -i linux-headers-3.16.0*.deb linux-image-3.16.0*.deb
Reboot the system.

sudo reboot

For 64-Bit Systems

Download the .deb packages.

$ wget kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-headers-3.16.0-031600_3.16.0-031600.201408031935_all.deb

$ wget kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-headers-3.16.0-031600-generic_3.16.0-031600.201408031935_amd64.deb

$ wget kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/linux-image-3.16.0-031600-generic_3.16.0-031600.201408031935_amd64.deb
Install them.

$ sudo dpkg -i linux-headers-3.16.0*.deb linux-image-3.16.0*.deb
Reboot the system.

sudo reboot

To uninstall,

sudo apt-get remove linux-headers-3.16.0* linux-image-3.16.0*

6 comments:

  1. already installed in ubuntu 14.04.1 so far so good, my brightness fn keys working again.

    ReplyDelete
  2. Installed it on Linux Mint 17.
    Perfect.

    ReplyDelete
  3. I installed it on Linux Mint 17 KDE (64bit) from the Konsole. Was very simple to install. Working very well. Thx!

    ReplyDelete
  4. Installed on Mint 17. Can no longer use rabbitmq in a docker container because su is broken. Rolled back.

    ReplyDelete
  5. My wifi RTL8188CU only works with 3.13.6. Not a newer kernel :-((

    ReplyDelete
    Replies
    1. Here's a guide on how to fix this: http://ubuntuforums.org/showthread.php?t=2216779&page=2

      Worked for me. Hope this helps. ;3

      Delete

    Total Pageviews